summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-69368/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/issue-69368/Makefile')
-rw-r--r--tests/run-make/issue-69368/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/run-make/issue-69368/Makefile b/tests/run-make/issue-69368/Makefile
new file mode 100644
index 000000000..b1229d1b0
--- /dev/null
+++ b/tests/run-make/issue-69368/Makefile
@@ -0,0 +1,19 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# Test that previously triggered a linker failure with root cause
+# similar to one found in the issue #69368.
+#
+# The crate that provides oom lang item is missing some other lang
+# items. Necessary to prevent the use of start-group / end-group.
+#
+# The weak lang items are defined in a separate compilation units,
+# so that linker could omit them if not used.
+#
+# The crates that need those weak lang items are dependencies of
+# crates that provide them.
+
+all:
+ $(RUSTC) a.rs
+ $(RUSTC) b.rs
+ $(RUSTC) c.rs