summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-7349/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/issue-7349/Makefile')
-rw-r--r--tests/run-make/issue-7349/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/run-make/issue-7349/Makefile b/tests/run-make/issue-7349/Makefile
new file mode 100644
index 000000000..dc073b77f
--- /dev/null
+++ b/tests/run-make/issue-7349/Makefile
@@ -0,0 +1,11 @@
+include ../tools.mk
+
+# Test to make sure that inner functions within a polymorphic outer function
+# don't get re-codegened when the outer function is monomorphized. The test
+# code monomorphizes the outer functions several times, but the magic constants
+# used in the inner functions should each appear only once in the generated IR.
+
+all:
+ $(RUSTC) foo.rs --emit=llvm-ir
+ [ "$$(grep -c 'ret i32 8675309' "$(TMPDIR)/foo.ll")" -eq "1" ]
+ [ "$$(grep -c 'ret i32 11235813' "$(TMPDIR)/foo.ll")" -eq "1" ]