summaryrefslogtreecommitdiffstats
path: root/tests/run-make/libs-through-symlinks/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/libs-through-symlinks/Makefile')
-rw-r--r--tests/run-make/libs-through-symlinks/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/libs-through-symlinks/Makefile b/tests/run-make/libs-through-symlinks/Makefile
new file mode 100644
index 000000000..592eae663
--- /dev/null
+++ b/tests/run-make/libs-through-symlinks/Makefile
@@ -0,0 +1,12 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# ignore-windows
+
+NAME := $(shell $(RUSTC) --print file-names foo.rs)
+
+all:
+ mkdir -p $(TMPDIR)/outdir
+ $(RUSTC) foo.rs -o $(TMPDIR)/outdir/$(NAME)
+ ln -nsf outdir/$(NAME) $(TMPDIR)
+ RUSTC_LOG=rustc_metadata::loader $(RUSTC) bar.rs