summaryrefslogtreecommitdiffstats
path: root/tests/run-make/link-arg/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/link-arg/Makefile')
-rw-r--r--tests/run-make/link-arg/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/run-make/link-arg/Makefile b/tests/run-make/link-arg/Makefile
new file mode 100644
index 000000000..103527c3e
--- /dev/null
+++ b/tests/run-make/link-arg/Makefile
@@ -0,0 +1,5 @@
+include ../tools.mk
+RUSTC_FLAGS = -C link-arg="-lfoo" -C link-arg="-lbar" --print link-args
+
+all:
+ $(RUSTC) $(RUSTC_FLAGS) empty.rs | $(CGREP) lfoo lbar