summaryrefslogtreecommitdiffstats
path: root/tests/run-make/link-dedup/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/link-dedup/Makefile')
-rw-r--r--tests/run-make/link-dedup/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/link-dedup/Makefile b/tests/run-make/link-dedup/Makefile
new file mode 100644
index 000000000..eff18ab48
--- /dev/null
+++ b/tests/run-make/link-dedup/Makefile
@@ -0,0 +1,12 @@
+# ignore-msvc
+
+include ../tools.mk
+
+all:
+ $(RUSTC) depa.rs
+ $(RUSTC) depb.rs
+ $(RUSTC) depc.rs
+ $(RUSTC) empty.rs --cfg bar 2>&1 | $(CGREP) '"-ltesta" "-ltestb" "-ltesta"'
+ $(RUSTC) empty.rs 2>&1 | $(CGREP) '"-ltesta"'
+ $(RUSTC) empty.rs 2>&1 | $(CGREP) -v '"-ltestb"'
+ $(RUSTC) empty.rs 2>&1 | $(CGREP) -v '"-ltesta" "-ltesta" "-ltesta"'