summaryrefslogtreecommitdiffstats
path: root/tests/run-make/linkage-attr-on-static
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/linkage-attr-on-static')
-rw-r--r--tests/run-make/linkage-attr-on-static/Makefile6
-rw-r--r--tests/run-make/linkage-attr-on-static/bar.rs16
-rw-r--r--tests/run-make/linkage-attr-on-static/foo.c7
3 files changed, 29 insertions, 0 deletions
diff --git a/tests/run-make/linkage-attr-on-static/Makefile b/tests/run-make/linkage-attr-on-static/Makefile
new file mode 100644
index 000000000..ef50a7ef9
--- /dev/null
+++ b/tests/run-make/linkage-attr-on-static/Makefile
@@ -0,0 +1,6 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all: $(call NATIVE_STATICLIB,foo)
+ $(RUSTC) bar.rs
+ $(call RUN,bar) || exit 1
diff --git a/tests/run-make/linkage-attr-on-static/bar.rs b/tests/run-make/linkage-attr-on-static/bar.rs
new file mode 100644
index 000000000..68607cbb6
--- /dev/null
+++ b/tests/run-make/linkage-attr-on-static/bar.rs
@@ -0,0 +1,16 @@
+#![feature(linkage)]
+
+#[no_mangle]
+#[linkage = "external"]
+static BAZ: i32 = 21;
+
+#[link(name = "foo", kind = "static")]
+extern "C" {
+ fn what() -> i32;
+}
+
+fn main() {
+ unsafe {
+ assert_eq!(what(), BAZ);
+ }
+}
diff --git a/tests/run-make/linkage-attr-on-static/foo.c b/tests/run-make/linkage-attr-on-static/foo.c
new file mode 100644
index 000000000..78a6934f5
--- /dev/null
+++ b/tests/run-make/linkage-attr-on-static/foo.c
@@ -0,0 +1,7 @@
+#include <stdint.h>
+
+extern int32_t BAZ;
+
+int32_t what() {
+ return BAZ;
+}