summaryrefslogtreecommitdiffstats
path: root/tests/run-make/ls-metadata/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/ls-metadata/Makefile')
-rw-r--r--tests/run-make/ls-metadata/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/run-make/ls-metadata/Makefile b/tests/run-make/ls-metadata/Makefile
new file mode 100644
index 000000000..123dd64e1
--- /dev/null
+++ b/tests/run-make/ls-metadata/Makefile
@@ -0,0 +1,8 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all:
+ $(RUSTC) foo.rs
+ $(RUSTC) -Z ls $(TMPDIR)/foo
+ touch $(TMPDIR)/bar
+ $(RUSTC) -Z ls $(TMPDIR)/bar