summaryrefslogtreecommitdiffstats
path: root/tests/run-make/lto-dylib-dep/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/lto-dylib-dep/Makefile')
-rw-r--r--tests/run-make/lto-dylib-dep/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/run-make/lto-dylib-dep/Makefile b/tests/run-make/lto-dylib-dep/Makefile
new file mode 100644
index 000000000..a9344597d
--- /dev/null
+++ b/tests/run-make/lto-dylib-dep/Makefile
@@ -0,0 +1,11 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# Test that we don't run into an assertion when using a Rust dylib dependency
+# while compiling with full LTO.
+# See https://github.com/rust-lang/rust/issues/59137
+
+all:
+ $(RUSTC) a_dylib.rs --crate-type=dylib -C prefer-dynamic
+ $(RUSTC) main.rs -C lto
+ $(call RUN,main)