summaryrefslogtreecommitdiffstats
path: root/tests/run-make/lto-empty
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/lto-empty')
-rw-r--r--tests/run-make/lto-empty/Makefile13
-rw-r--r--tests/run-make/lto-empty/lib.rs1
2 files changed, 14 insertions, 0 deletions
diff --git a/tests/run-make/lto-empty/Makefile b/tests/run-make/lto-empty/Makefile
new file mode 100644
index 000000000..1b795c4b7
--- /dev/null
+++ b/tests/run-make/lto-empty/Makefile
@@ -0,0 +1,13 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all: cdylib-fat cdylib-thin
+
+cdylib-fat:
+ $(RUSTC) lib.rs -C lto=fat -C opt-level=3 -C incremental=$(TMPDIR)/inc-fat
+ $(RUSTC) lib.rs -C lto=fat -C opt-level=3 -C incremental=$(TMPDIR)/inc-fat
+
+cdylib-thin:
+ $(RUSTC) lib.rs -C lto=thin -C opt-level=3 -C incremental=$(TMPDIR)/inc-thin
+ $(RUSTC) lib.rs -C lto=thin -C opt-level=3 -C incremental=$(TMPDIR)/inc-thin
+
diff --git a/tests/run-make/lto-empty/lib.rs b/tests/run-make/lto-empty/lib.rs
new file mode 100644
index 000000000..e3663c790
--- /dev/null
+++ b/tests/run-make/lto-empty/lib.rs
@@ -0,0 +1 @@
+#![crate_type = "cdylib"]