summaryrefslogtreecommitdiffstats
path: root/tests/run-make/lto-no-link-whole-rlib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/lto-no-link-whole-rlib/Makefile')
-rw-r--r--tests/run-make/lto-no-link-whole-rlib/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/run-make/lto-no-link-whole-rlib/Makefile b/tests/run-make/lto-no-link-whole-rlib/Makefile
new file mode 100644
index 000000000..3e82322e7
--- /dev/null
+++ b/tests/run-make/lto-no-link-whole-rlib/Makefile
@@ -0,0 +1,9 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all: $(call NATIVE_STATICLIB,foo) $(call NATIVE_STATICLIB,bar)
+ $(RUSTC) lib1.rs
+ $(RUSTC) lib2.rs
+ $(RUSTC) main.rs -Clto
+ $(call RUN,main)
+