summaryrefslogtreecommitdiffstats
path: root/tests/run-make/lto-readonly-lib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/lto-readonly-lib/Makefile')
-rw-r--r--tests/run-make/lto-readonly-lib/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/run-make/lto-readonly-lib/Makefile b/tests/run-make/lto-readonly-lib/Makefile
new file mode 100644
index 000000000..11d944e3e
--- /dev/null
+++ b/tests/run-make/lto-readonly-lib/Makefile
@@ -0,0 +1,13 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all:
+ $(RUSTC) lib.rs
+
+ # the compiler needs to copy and modify the rlib file when performing
+ # LTO, so we should ensure that it can cope with the original rlib
+ # being read-only.
+ chmod 444 $(TMPDIR)/*.rlib
+
+ $(RUSTC) main.rs -C lto
+ $(call RUN,main)