summaryrefslogtreecommitdiffstats
path: root/tests/run-make/lto-smoke-c/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/lto-smoke-c/Makefile')
-rw-r--r--tests/run-make/lto-smoke-c/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/lto-smoke-c/Makefile b/tests/run-make/lto-smoke-c/Makefile
new file mode 100644
index 000000000..f1ba3d95d
--- /dev/null
+++ b/tests/run-make/lto-smoke-c/Makefile
@@ -0,0 +1,12 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# Apparently older versions of GCC segfault if -g is passed...
+CC := $(CC:-g=)
+
+all:
+ $(RUSTC) foo.rs -C lto
+ $(CC) bar.c $(call STATICLIB,foo) \
+ $(call OUT_EXE,bar) \
+ $(EXTRACFLAGS) $(EXTRACXXFLAGS)
+ $(call RUN,bar)