summaryrefslogtreecommitdiffstats
path: root/tests/run-make/lto-smoke/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/lto-smoke/Makefile')
-rw-r--r--tests/run-make/lto-smoke/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/tests/run-make/lto-smoke/Makefile b/tests/run-make/lto-smoke/Makefile
new file mode 100644
index 000000000..13a09fce7
--- /dev/null
+++ b/tests/run-make/lto-smoke/Makefile
@@ -0,0 +1,31 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all: noparam bool_true bool_false thin fat
+
+noparam:
+ $(RUSTC) lib.rs
+ $(RUSTC) main.rs -C lto
+ $(call RUN,main)
+
+bool_true:
+ $(RUSTC) lib.rs
+ $(RUSTC) main.rs -C lto=yes
+ $(call RUN,main)
+
+
+bool_false:
+ $(RUSTC) lib.rs
+ $(RUSTC) main.rs -C lto=off
+ $(call RUN,main)
+
+thin:
+ $(RUSTC) lib.rs
+ $(RUSTC) main.rs -C lto=thin
+ $(call RUN,main)
+
+fat:
+ $(RUSTC) lib.rs
+ $(RUSTC) main.rs -C lto=fat
+ $(call RUN,main)
+