summaryrefslogtreecommitdiffstats
path: root/tests/run-make/min-global-align/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/min-global-align/Makefile')
-rw-r--r--tests/run-make/min-global-align/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/tests/run-make/min-global-align/Makefile b/tests/run-make/min-global-align/Makefile
new file mode 100644
index 000000000..82f38749e
--- /dev/null
+++ b/tests/run-make/min-global-align/Makefile
@@ -0,0 +1,22 @@
+include ../tools.mk
+
+# only-linux
+
+# This tests ensure that global variables respect the target minimum alignment.
+# The three bools `STATIC_BOOL`, `STATIC_MUT_BOOL`, and `CONST_BOOL` all have
+# type-alignment of 1, but some targets require greater global alignment.
+
+SRC = min_global_align.rs
+LL = $(TMPDIR)/min_global_align.ll
+
+all:
+# Most targets are happy with default alignment -- take i686 for example.
+ifeq ($(filter x86,$(LLVM_COMPONENTS)),x86)
+ $(RUSTC) --target=i686-unknown-linux-gnu --emit=llvm-ir $(SRC)
+ [ "$$(grep -c 'align 1' "$(LL)")" -eq "3" ]
+endif
+# SystemZ requires even alignment for PC-relative addressing.
+ifeq ($(filter systemz,$(LLVM_COMPONENTS)),systemz)
+ $(RUSTC) --target=s390x-unknown-linux-gnu --emit=llvm-ir $(SRC)
+ [ "$$(grep -c 'align 2' "$(LL)")" -eq "3" ]
+endif