summaryrefslogtreecommitdiffstats
path: root/tests/run-make/mingw-export-call-convention/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/mingw-export-call-convention/Makefile')
-rw-r--r--tests/run-make/mingw-export-call-convention/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/run-make/mingw-export-call-convention/Makefile b/tests/run-make/mingw-export-call-convention/Makefile
new file mode 100644
index 000000000..4a60059cc
--- /dev/null
+++ b/tests/run-make/mingw-export-call-convention/Makefile
@@ -0,0 +1,9 @@
+include ../tools.mk
+
+# only-windows-gnu
+
+all:
+ $(RUSTC) foo.rs
+ # FIXME: we should make sure __stdcall calling convention is used here
+ # but that only works with LLD right now
+ nm -g "$(call IMPLIB,foo)" | $(CGREP) bar