summaryrefslogtreecommitdiffstats
path: root/tests/run-make/mismatching-target-triples/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/mismatching-target-triples/Makefile')
-rw-r--r--tests/run-make/mismatching-target-triples/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/run-make/mismatching-target-triples/Makefile b/tests/run-make/mismatching-target-triples/Makefile
new file mode 100644
index 000000000..409388e04
--- /dev/null
+++ b/tests/run-make/mismatching-target-triples/Makefile
@@ -0,0 +1,11 @@
+include ../tools.mk
+
+# Issue #10814
+#
+# these are no_std to avoid having to have the standard library or any
+# linkers/assemblers for the relevant platform
+
+all:
+ $(RUSTC) foo.rs --target=i686-unknown-linux-gnu
+ $(RUSTC) bar.rs --target=x86_64-unknown-linux-gnu 2>&1 \
+ | $(CGREP) 'couldn'"'"'t find crate `foo` with expected target triple x86_64-unknown-linux-gnu'