summaryrefslogtreecommitdiffstats
path: root/tests/run-make/mixing-libs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/mixing-libs/Makefile')
-rw-r--r--tests/run-make/mixing-libs/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/run-make/mixing-libs/Makefile b/tests/run-make/mixing-libs/Makefile
new file mode 100644
index 000000000..e8262b284
--- /dev/null
+++ b/tests/run-make/mixing-libs/Makefile
@@ -0,0 +1,10 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all:
+ $(RUSTC) rlib.rs
+ $(RUSTC) dylib.rs
+ $(RUSTC) rlib.rs --crate-type=dylib
+ $(RUSTC) dylib.rs
+ $(call REMOVE_DYLIBS,rlib)
+ $(RUSTC) prog.rs && exit 1 || exit 0