summaryrefslogtreecommitdiffstats
path: root/tests/run-make/no-duplicate-libs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/no-duplicate-libs/Makefile')
-rw-r--r--tests/run-make/no-duplicate-libs/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/run-make/no-duplicate-libs/Makefile b/tests/run-make/no-duplicate-libs/Makefile
new file mode 100644
index 000000000..4be8c0262
--- /dev/null
+++ b/tests/run-make/no-duplicate-libs/Makefile
@@ -0,0 +1,11 @@
+# ignore-cross-compile
+include ../tools.mk
+
+ifdef IS_MSVC
+# FIXME(#27979)
+all:
+else
+all: $(call STATICLIB,foo) $(call STATICLIB,bar)
+ $(RUSTC) main.rs
+ $(call RUN,main)
+endif