summaryrefslogtreecommitdiffstats
path: root/tests/run-make/obey-crate-type-flag/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/obey-crate-type-flag/Makefile')
-rw-r--r--tests/run-make/obey-crate-type-flag/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/run-make/obey-crate-type-flag/Makefile b/tests/run-make/obey-crate-type-flag/Makefile
new file mode 100644
index 000000000..ecbb2e620
--- /dev/null
+++ b/tests/run-make/obey-crate-type-flag/Makefile
@@ -0,0 +1,14 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# check that rustc builds all crate_type attributes
+# delete rlib
+# delete whatever dylib is made for this system
+# check that rustc only builds --crate-type flags, ignoring attributes
+# fail if an rlib was built
+all:
+ $(RUSTC) test.rs
+ $(call REMOVE_RLIBS,test)
+ $(call REMOVE_DYLIBS,test)
+ $(RUSTC) --crate-type dylib test.rs
+ $(call REMOVE_RLIBS,test) && exit 1 || exit 0