summaryrefslogtreecommitdiffstats
path: root/tests/run-make/optimization-remarks-dir-pgo
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/optimization-remarks-dir-pgo')
-rw-r--r--tests/run-make/optimization-remarks-dir-pgo/Makefile21
-rw-r--r--tests/run-make/optimization-remarks-dir-pgo/foo.rs6
2 files changed, 27 insertions, 0 deletions
diff --git a/tests/run-make/optimization-remarks-dir-pgo/Makefile b/tests/run-make/optimization-remarks-dir-pgo/Makefile
new file mode 100644
index 000000000..3bc3d7d14
--- /dev/null
+++ b/tests/run-make/optimization-remarks-dir-pgo/Makefile
@@ -0,0 +1,21 @@
+# needs-profiler-support
+# ignore-windows-gnu
+# ignore-cross-compile
+
+# FIXME(mati865): MinGW GCC miscompiles compiler-rt profiling library but with Clang it works
+# properly. Since we only have GCC on the CI ignore the test for now.
+
+include ../tools.mk
+
+PROFILE_DIR=$(TMPDIR)/profiles
+
+check_hotness:
+ $(RUSTC) -Cprofile-generate="$(TMPDIR)"/profdata -O foo.rs -o$(TMPDIR)/foo
+ $(TMPDIR)/foo
+ "$(LLVM_BIN_DIR)"/llvm-profdata merge \
+ -o "$(TMPDIR)"/merged.profdata \
+ "$(TMPDIR)"/profdata/*.profraw
+ $(RUSTC) -Cprofile-use=$(TMPDIR)/merged.profdata -O foo.rs -Cremark=all -Zremark-dir=$(PROFILE_DIR)
+
+ # Check that PGO hotness is included in the remark files
+ cat $(PROFILE_DIR)/*.opt.yaml | $(CGREP) -e "Hotness"
diff --git a/tests/run-make/optimization-remarks-dir-pgo/foo.rs b/tests/run-make/optimization-remarks-dir-pgo/foo.rs
new file mode 100644
index 000000000..f7ca18263
--- /dev/null
+++ b/tests/run-make/optimization-remarks-dir-pgo/foo.rs
@@ -0,0 +1,6 @@
+#[inline(never)]
+pub fn bar() {}
+
+fn main() {
+ bar();
+}