summaryrefslogtreecommitdiffstats
path: root/tests/run-make/output-filename-conflicts-with-directory/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/output-filename-conflicts-with-directory/Makefile')
-rw-r--r--tests/run-make/output-filename-conflicts-with-directory/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/run-make/output-filename-conflicts-with-directory/Makefile b/tests/run-make/output-filename-conflicts-with-directory/Makefile
new file mode 100644
index 000000000..45221356c
--- /dev/null
+++ b/tests/run-make/output-filename-conflicts-with-directory/Makefile
@@ -0,0 +1,7 @@
+include ../tools.mk
+
+all:
+ cp foo.rs $(TMPDIR)/foo.rs
+ mkdir $(TMPDIR)/foo
+ $(RUSTC) $(TMPDIR)/foo.rs -o $(TMPDIR)/foo 2>&1 \
+ | $(CGREP) -e "the generated executable for the input file \".*foo\.rs\" conflicts with the existing directory \".*foo\""