summaryrefslogtreecommitdiffstats
path: root/tests/run-make/output-with-hyphens/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/output-with-hyphens/Makefile')
-rw-r--r--tests/run-make/output-with-hyphens/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/run-make/output-with-hyphens/Makefile b/tests/run-make/output-with-hyphens/Makefile
new file mode 100644
index 000000000..846c9a66a
--- /dev/null
+++ b/tests/run-make/output-with-hyphens/Makefile
@@ -0,0 +1,8 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all:
+ $(RUSTC) foo-bar.rs --crate-type bin
+ [ -f $(TMPDIR)/$(call BIN,foo-bar) ]
+ $(RUSTC) foo-bar.rs --crate-type lib
+ [ -f $(TMPDIR)/libfoo_bar.rlib ]