summaryrefslogtreecommitdiffstats
path: root/tests/run-make/panic-abort-eh_frame/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/panic-abort-eh_frame/Makefile')
-rw-r--r--tests/run-make/panic-abort-eh_frame/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/run-make/panic-abort-eh_frame/Makefile b/tests/run-make/panic-abort-eh_frame/Makefile
new file mode 100644
index 000000000..1cb7bf575
--- /dev/null
+++ b/tests/run-make/panic-abort-eh_frame/Makefile
@@ -0,0 +1,10 @@
+# only-linux
+#
+# This test ensures that `panic=abort` code (without `C-unwind`, that is) should not have any
+# unwinding related `.eh_frame` sections emitted.
+
+include ../tools.mk
+
+all:
+ $(RUSTC) foo.rs --crate-type=lib --emit=obj=$(TMPDIR)/foo.o -Cpanic=abort
+ objdump --dwarf=frames $(TMPDIR)/foo.o | $(CGREP) -v 'DW_CFA'