summaryrefslogtreecommitdiffstats
path: root/tests/run-make/panic-impl-transitive/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/panic-impl-transitive/Makefile')
-rw-r--r--tests/run-make/panic-impl-transitive/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/run-make/panic-impl-transitive/Makefile b/tests/run-make/panic-impl-transitive/Makefile
new file mode 100644
index 000000000..9a271a22e
--- /dev/null
+++ b/tests/run-make/panic-impl-transitive/Makefile
@@ -0,0 +1,7 @@
+include ../tools.mk
+
+# NOTE we use --emit=llvm-ir to avoid running the linker (linking will fail because there's no main
+# in this crate)
+all:
+ $(RUSTC) panic-impl-provider.rs
+ $(RUSTC) panic-impl-consumer.rs -C panic=abort --emit=llvm-ir -L $(TMPDIR)