summaryrefslogtreecommitdiffstats
path: root/tests/run-make/pgo-gen-no-imp-symbols/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/pgo-gen-no-imp-symbols/Makefile')
-rw-r--r--tests/run-make/pgo-gen-no-imp-symbols/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/run-make/pgo-gen-no-imp-symbols/Makefile b/tests/run-make/pgo-gen-no-imp-symbols/Makefile
new file mode 100644
index 000000000..7f72b11b6
--- /dev/null
+++ b/tests/run-make/pgo-gen-no-imp-symbols/Makefile
@@ -0,0 +1,13 @@
+# needs-profiler-support
+
+include ../tools.mk
+
+COMPILE_FLAGS=-O -Ccodegen-units=1 -Cprofile-generate="$(TMPDIR)"
+
+all:
+ $(RUSTC) $(COMPILE_FLAGS) --emit=llvm-ir test.rs
+ # We expect symbols starting with "__llvm_profile_".
+ $(CGREP) "__llvm_profile_" < $(TMPDIR)/test.ll
+ # We do NOT expect the "__imp_" version of these symbols.
+ $(CGREP) -v "__imp___llvm_profile_" < $(TMPDIR)/test.ll # 64 bit
+ $(CGREP) -v "__imp____llvm_profile_" < $(TMPDIR)/test.ll # 32 bit