summaryrefslogtreecommitdiffstats
path: root/tests/run-make/pgo-gen/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/pgo-gen/Makefile')
-rw-r--r--tests/run-make/pgo-gen/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/run-make/pgo-gen/Makefile b/tests/run-make/pgo-gen/Makefile
new file mode 100644
index 000000000..4623a7495
--- /dev/null
+++ b/tests/run-make/pgo-gen/Makefile
@@ -0,0 +1,14 @@
+# needs-profiler-support
+# ignore-windows-gnu
+
+# FIXME(mati865): MinGW GCC miscompiles compiler-rt profiling library but with Clang it works
+# properly. Since we only have GCC on the CI ignore the test for now.
+
+include ../tools.mk
+
+COMPILE_FLAGS=-g -Cprofile-generate="$(TMPDIR)"
+
+all:
+ $(RUSTC) $(COMPILE_FLAGS) test.rs
+ $(call RUN,test) || exit 1
+ [ -e "$(TMPDIR)"/default_*.profraw ] || (echo "No .profraw file"; exit 1)