summaryrefslogtreecommitdiffstats
path: root/tests/run-make/pointer-auth-link-with-c/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/pointer-auth-link-with-c/Makefile')
-rw-r--r--tests/run-make/pointer-auth-link-with-c/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/run-make/pointer-auth-link-with-c/Makefile b/tests/run-make/pointer-auth-link-with-c/Makefile
new file mode 100644
index 000000000..7acea0380
--- /dev/null
+++ b/tests/run-make/pointer-auth-link-with-c/Makefile
@@ -0,0 +1,14 @@
+include ../tools.mk
+
+# only-aarch64
+
+all:
+ $(COMPILE_OBJ) $(TMPDIR)/test.o test.c
+ $(AR) rcs $(TMPDIR)/libtest.a $(TMPDIR)/test.o
+ $(RUSTC) -Z branch-protection=bti,pac-ret,leaf test.rs
+ $(call RUN,test)
+
+ $(COMPILE_OBJ) $(TMPDIR)/test.o test.c -mbranch-protection=bti+pac-ret+leaf
+ $(AR) rcs $(TMPDIR)/libtest.a $(TMPDIR)/test.o
+ $(RUSTC) -Z branch-protection=bti,pac-ret,leaf test.rs
+ $(call RUN,test)