summaryrefslogtreecommitdiffstats
path: root/tests/run-make/prefer-rlib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/prefer-rlib/Makefile')
-rw-r--r--tests/run-make/prefer-rlib/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/run-make/prefer-rlib/Makefile b/tests/run-make/prefer-rlib/Makefile
new file mode 100644
index 000000000..2e86b9c1d
--- /dev/null
+++ b/tests/run-make/prefer-rlib/Makefile
@@ -0,0 +1,9 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all:
+ $(RUSTC) bar.rs --crate-type=dylib --crate-type=rlib
+ ls $(TMPDIR)/$(call RLIB_GLOB,bar)
+ $(RUSTC) foo.rs
+ rm $(TMPDIR)/*bar*
+ $(call RUN,foo)