summaryrefslogtreecommitdiffstats
path: root/tests/run-make/pretty-print-with-dep-file/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/pretty-print-with-dep-file/Makefile')
-rw-r--r--tests/run-make/pretty-print-with-dep-file/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/run-make/pretty-print-with-dep-file/Makefile b/tests/run-make/pretty-print-with-dep-file/Makefile
new file mode 100644
index 000000000..fa8089eb6
--- /dev/null
+++ b/tests/run-make/pretty-print-with-dep-file/Makefile
@@ -0,0 +1,9 @@
+include ../tools.mk
+
+all:
+ $(RUSTC) --emit=dep-info -Zunpretty=expanded with-dep.rs
+ $(CGREP) "with-dep.rs" < $(TMPDIR)/with-dep.d
+ -rm $(TMPDIR)/with-dep.d
+
+ $(RUSTC) --emit=dep-info -Zunpretty=normal with-dep.rs
+ ! test -f $(TMPDIR)/with-dep.d