summaryrefslogtreecommitdiffstats
path: root/tests/run-make/print-cfg/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/print-cfg/Makefile')
-rw-r--r--tests/run-make/print-cfg/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/run-make/print-cfg/Makefile b/tests/run-make/print-cfg/Makefile
new file mode 100644
index 000000000..126f5768c
--- /dev/null
+++ b/tests/run-make/print-cfg/Makefile
@@ -0,0 +1,20 @@
+# needs-llvm-components: x86 arm
+
+include ../tools.mk
+
+all: default
+ $(RUSTC) --target x86_64-pc-windows-gnu --print cfg | $(CGREP) windows
+ $(RUSTC) --target x86_64-pc-windows-gnu --print cfg | $(CGREP) x86_64
+ $(RUSTC) --target i686-pc-windows-msvc --print cfg | $(CGREP) msvc
+ $(RUSTC) --target i686-apple-darwin --print cfg | $(CGREP) macos
+ $(RUSTC) --target i686-unknown-linux-gnu --print cfg | $(CGREP) gnu
+ $(RUSTC) --target arm-unknown-linux-gnueabihf --print cfg | $(CGREP) target_abi=
+ $(RUSTC) --target arm-unknown-linux-gnueabihf --print cfg | $(CGREP) eabihf
+
+ifdef IS_WINDOWS
+default:
+ $(RUSTC) --print cfg | $(CGREP) windows
+else
+default:
+ $(RUSTC) --print cfg | $(CGREP) unix
+endif