summaryrefslogtreecommitdiffstats
path: root/tests/run-make/print-target-list/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/print-target-list/Makefile')
-rw-r--r--tests/run-make/print-target-list/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/run-make/print-target-list/Makefile b/tests/run-make/print-target-list/Makefile
new file mode 100644
index 000000000..f23c40d42
--- /dev/null
+++ b/tests/run-make/print-target-list/Makefile
@@ -0,0 +1,8 @@
+include ../tools.mk
+
+# Checks that all the targets returned by `rustc --print target-list` are valid
+# target specifications
+all:
+ for target in $(shell $(BARE_RUSTC) --print target-list); do \
+ $(BARE_RUSTC) --target $$target --print sysroot; \
+ done