summaryrefslogtreecommitdiffstats
path: root/tests/run-make/profile/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/profile/Makefile')
-rw-r--r--tests/run-make/profile/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/profile/Makefile b/tests/run-make/profile/Makefile
new file mode 100644
index 000000000..fffc051ad
--- /dev/null
+++ b/tests/run-make/profile/Makefile
@@ -0,0 +1,12 @@
+# needs-profiler-support
+
+include ../tools.mk
+
+all:
+ $(RUSTC) -g -Z profile test.rs
+ $(call RUN,test) || exit 1
+ [ -e "$(TMPDIR)/test.gcno" ] || (echo "No .gcno file"; exit 1)
+ [ -e "$(TMPDIR)/test.gcda" ] || (echo "No .gcda file"; exit 1)
+ $(RUSTC) -g -Z profile -Z profile-emit=$(TMPDIR)/abc/abc.gcda test.rs
+ $(call RUN,test) || exit 1
+ [ -e "$(TMPDIR)/abc/abc.gcda" ] || (echo "gcda file not emitted to defined path"; exit 1)