summaryrefslogtreecommitdiffstats
path: root/tests/run-make/relocation-model/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/relocation-model/Makefile')
-rw-r--r--tests/run-make/relocation-model/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/run-make/relocation-model/Makefile b/tests/run-make/relocation-model/Makefile
new file mode 100644
index 000000000..8cc5205ed
--- /dev/null
+++ b/tests/run-make/relocation-model/Makefile
@@ -0,0 +1,20 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all: others
+ $(RUSTC) -C relocation-model=dynamic-no-pic foo.rs
+ $(call RUN,foo)
+
+ $(RUSTC) -C relocation-model=default foo.rs
+ $(call RUN,foo)
+
+ $(RUSTC) -C relocation-model=dynamic-no-pic --crate-type=dylib foo.rs --emit=link,obj
+
+ifdef IS_MSVC
+# FIXME(#28026)
+others:
+else
+others:
+ $(RUSTC) -C relocation-model=static foo.rs
+ $(call RUN,foo)
+endif