summaryrefslogtreecommitdiffstats
path: root/tests/run-make/remap-path-prefix/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/remap-path-prefix/Makefile')
-rw-r--r--tests/run-make/remap-path-prefix/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/run-make/remap-path-prefix/Makefile b/tests/run-make/remap-path-prefix/Makefile
new file mode 100644
index 000000000..2a7378fdf
--- /dev/null
+++ b/tests/run-make/remap-path-prefix/Makefile
@@ -0,0 +1,9 @@
+include ../tools.mk
+
+# ignore-windows
+
+# Checks if remapping works if the remap-from string contains path to the working directory plus more
+all:
+ $(RUSTC) --remap-path-prefix $$PWD/auxiliary=/the/aux --crate-type=lib --emit=metadata auxiliary/lib.rs
+ grep "/the/aux/lib.rs" $(TMPDIR)/liblib.rmeta || exit 1
+ ! grep "$$PWD/auxiliary" $(TMPDIR)/liblib.rmeta || exit 1