summaryrefslogtreecommitdiffstats
path: root/tests/run-make/rustdoc-determinism/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/rustdoc-determinism/Makefile')
-rw-r--r--tests/run-make/rustdoc-determinism/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/run-make/rustdoc-determinism/Makefile b/tests/run-make/rustdoc-determinism/Makefile
new file mode 100644
index 000000000..a3ef16906
--- /dev/null
+++ b/tests/run-make/rustdoc-determinism/Makefile
@@ -0,0 +1,16 @@
+include ../tools.mk
+
+# Assert that the search index is generated deterministically, regardless of the
+# order that crates are documented in.
+
+# ignore-windows
+# Uses `diff`.
+
+all:
+ $(RUSTDOC) foo.rs -o $(TMPDIR)/foo_first
+ $(RUSTDOC) bar.rs -o $(TMPDIR)/foo_first
+
+ $(RUSTDOC) bar.rs -o $(TMPDIR)/bar_first
+ $(RUSTDOC) foo.rs -o $(TMPDIR)/bar_first
+
+ diff $(TMPDIR)/foo_first/search-index.js $(TMPDIR)/bar_first/search-index.js