summaryrefslogtreecommitdiffstats
path: root/tests/run-make/rustdoc-target-spec-json-path/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/rustdoc-target-spec-json-path/Makefile')
-rw-r--r--tests/run-make/rustdoc-target-spec-json-path/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/run-make/rustdoc-target-spec-json-path/Makefile b/tests/run-make/rustdoc-target-spec-json-path/Makefile
new file mode 100644
index 000000000..6d0bc4186
--- /dev/null
+++ b/tests/run-make/rustdoc-target-spec-json-path/Makefile
@@ -0,0 +1,9 @@
+include ../tools.mk
+
+# Test that rustdoc will properly canonicalize the target spec json path just like rustc
+
+OUTPUT_DIR := "$(TMPDIR)/rustdoc-target-spec-json-path"
+
+all:
+ $(RUSTC) --crate-type lib dummy_core.rs --target target.json
+ $(RUSTDOC) -o $(OUTPUT_DIR) -L $(TMPDIR) my_crate.rs --target target.json