summaryrefslogtreecommitdiffstats
path: root/tests/run-make/rustdoc-themes/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/rustdoc-themes/Makefile')
-rw-r--r--tests/run-make/rustdoc-themes/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/run-make/rustdoc-themes/Makefile b/tests/run-make/rustdoc-themes/Makefile
new file mode 100644
index 000000000..a6d9a43ad
--- /dev/null
+++ b/tests/run-make/rustdoc-themes/Makefile
@@ -0,0 +1,10 @@
+include ../tools.mk
+
+# Test that rustdoc will properly load in a theme file and display it in the theme selector.
+
+OUTPUT_DIR := "$(TMPDIR)/rustdoc-themes"
+
+all:
+ cp $(S)/src/librustdoc/html/static/css/themes/light.css $(TMPDIR)/test.css
+ $(RUSTDOC) -o $(OUTPUT_DIR) foo.rs --theme $(TMPDIR)/test.css
+ $(HTMLDOCCK) $(OUTPUT_DIR) foo.rs