summaryrefslogtreecommitdiffstats
path: root/tests/run-make/sanitizer-dylib-link/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/sanitizer-dylib-link/Makefile')
-rw-r--r--tests/run-make/sanitizer-dylib-link/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/run-make/sanitizer-dylib-link/Makefile b/tests/run-make/sanitizer-dylib-link/Makefile
new file mode 100644
index 000000000..b0a91e5b1
--- /dev/null
+++ b/tests/run-make/sanitizer-dylib-link/Makefile
@@ -0,0 +1,16 @@
+# needs-sanitizer-support
+# needs-sanitizer-address
+
+include ../tools.mk
+
+LOG := $(TMPDIR)/log.txt
+
+# This test builds a shared object, then an executable that links it as a native
+# rust library (contrast to an rlib). The shared library and executable both
+# are compiled with address sanitizer, and we assert that a fault in the dylib
+# is correctly detected.
+
+all:
+ $(RUSTC) -g -Z sanitizer=address --crate-type dylib --target $(TARGET) library.rs
+ $(RUSTC) -g -Z sanitizer=address --crate-type bin --target $(TARGET) -llibrary program.rs
+ LD_LIBRARY_PATH=$(TMPDIR) $(TMPDIR)/program 2>&1 | $(CGREP) stack-buffer-overflow