summaryrefslogtreecommitdiffstats
path: root/tests/run-make/sanitizer-staticlib-link/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/sanitizer-staticlib-link/Makefile')
-rw-r--r--tests/run-make/sanitizer-staticlib-link/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/run-make/sanitizer-staticlib-link/Makefile b/tests/run-make/sanitizer-staticlib-link/Makefile
new file mode 100644
index 000000000..7b1a286ed
--- /dev/null
+++ b/tests/run-make/sanitizer-staticlib-link/Makefile
@@ -0,0 +1,20 @@
+# needs-sanitizer-support
+# needs-sanitizer-address
+
+include ../tools.mk
+
+# This test first builds a staticlib with AddressSanitizer and checks that
+# linking it to an executable fails due to the missing sanitizer runtime.
+# It then builds an executable linking to the staticlib and checks that
+# the fault in the staticlib is detected correctly.
+
+# Note that checking for the link failure actually checks two things at once:
+# 1) That the library has the sanitizer intrumentation
+# 2) and that library does not have the sanitizer runtime
+
+all:
+ $(RUSTC) -g -Z sanitizer=address --crate-type staticlib --target $(TARGET) library.rs
+ ! $(CC) program.c $(call STATICLIB,library) $(call OUT_EXE,program) $(EXTRACFLAGS) $(EXTRACXXFLAGS)
+ $(RUSTC) -g -Z sanitizer=address --crate-type bin --target $(TARGET) -L . program.rs
+ LD_LIBRARY_PATH=$(TMPDIR) $(TMPDIR)/program 2>&1 | $(CGREP) stack-buffer-overflow
+