summaryrefslogtreecommitdiffstats
path: root/tests/run-make/separate-link-fail/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/separate-link-fail/Makefile')
-rw-r--r--tests/run-make/separate-link-fail/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/run-make/separate-link-fail/Makefile b/tests/run-make/separate-link-fail/Makefile
new file mode 100644
index 000000000..bfd18fbf9
--- /dev/null
+++ b/tests/run-make/separate-link-fail/Makefile
@@ -0,0 +1,7 @@
+include ../tools.mk
+
+all:
+ echo 'fn main(){}' > $(TMPDIR)/main.rs
+ # Make sure that this fails
+ ! $(RUSTC) -Z link-only $(TMPDIR)/main.rs 2> $(TMPDIR)/stderr.txt
+ $(CGREP) "The input does not look like a .rlink file" < $(TMPDIR)/stderr.txt