summaryrefslogtreecommitdiffstats
path: root/tests/run-make/separate-link/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/separate-link/Makefile')
-rw-r--r--tests/run-make/separate-link/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/run-make/separate-link/Makefile b/tests/run-make/separate-link/Makefile
new file mode 100644
index 000000000..d01158d9f
--- /dev/null
+++ b/tests/run-make/separate-link/Makefile
@@ -0,0 +1,7 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all:
+ echo 'fn main(){}' | $(RUSTC) -Z no-link -
+ $(RUSTC) -Z link-only $(TMPDIR)/rust_out.rlink
+ $(call RUN,rust_out)