summaryrefslogtreecommitdiffstats
path: root/tests/run-make/sepcomp-cci-copies/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/sepcomp-cci-copies/Makefile')
-rw-r--r--tests/run-make/sepcomp-cci-copies/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/sepcomp-cci-copies/Makefile b/tests/run-make/sepcomp-cci-copies/Makefile
new file mode 100644
index 000000000..df289d0b0
--- /dev/null
+++ b/tests/run-make/sepcomp-cci-copies/Makefile
@@ -0,0 +1,12 @@
+include ../tools.mk
+
+# Check that cross-crate inlined items are inlined in all compilation units
+# that refer to them, and not in any other compilation units.
+# Note that we have to pass `-C codegen-units=6` because up to two CGUs may be
+# created for each source module (see `rustc_const_eval::monomorphize::partitioning`).
+
+all:
+ $(RUSTC) cci_lib.rs
+ $(RUSTC) foo.rs --emit=llvm-ir -C codegen-units=6 \
+ -Z inline-in-all-cgus
+ [ "$$(cat "$(TMPDIR)"/foo.*.ll | grep -c define\ .*cci_fn)" -eq "2" ]