summaryrefslogtreecommitdiffstats
path: root/tests/run-make/static-dylib-by-default/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/static-dylib-by-default/Makefile')
-rw-r--r--tests/run-make/static-dylib-by-default/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/run-make/static-dylib-by-default/Makefile b/tests/run-make/static-dylib-by-default/Makefile
new file mode 100644
index 000000000..cdaab42d0
--- /dev/null
+++ b/tests/run-make/static-dylib-by-default/Makefile
@@ -0,0 +1,17 @@
+# ignore-cross-compile
+include ../tools.mk
+
+TO_LINK := $(call DYLIB,bar)
+ifdef IS_MSVC
+LINK_ARG = $(TO_LINK:dll=dll.lib)
+else
+LINK_ARG = $(TO_LINK)
+endif
+
+all:
+ $(RUSTC) foo.rs
+ $(RUSTC) bar.rs
+ $(CC) main.c $(call OUT_EXE,main) $(LINK_ARG) $(EXTRACFLAGS)
+ rm $(TMPDIR)/*.rlib
+ rm $(call DYLIB,foo)
+ $(call RUN,main)