summaryrefslogtreecommitdiffstats
path: root/tests/run-make/std-core-cycle/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/std-core-cycle/Makefile')
-rw-r--r--tests/run-make/std-core-cycle/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/run-make/std-core-cycle/Makefile b/tests/run-make/std-core-cycle/Makefile
new file mode 100644
index 000000000..5ed6be905
--- /dev/null
+++ b/tests/run-make/std-core-cycle/Makefile
@@ -0,0 +1,17 @@
+# ignore-cross-compile
+include ../tools.mk
+
+ifeq ($(UNAME),Darwin)
+FLAGS :=
+else
+ifdef IS_WINDOWS
+FLAGS :=
+else
+FLAGS := -C link-args=-Wl,--no-undefined
+endif
+endif
+
+all:
+ $(RUSTC) bar.rs
+ $(RUSTC) foo.rs $(FLAGS)
+ $(RUSTC) foo.rs $(FLAGS) -C panic=abort