summaryrefslogtreecommitdiffstats
path: root/tests/run-make/symbols-include-type-name/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/symbols-include-type-name/Makefile')
-rw-r--r--tests/run-make/symbols-include-type-name/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/run-make/symbols-include-type-name/Makefile b/tests/run-make/symbols-include-type-name/Makefile
new file mode 100644
index 000000000..ac26a852e
--- /dev/null
+++ b/tests/run-make/symbols-include-type-name/Makefile
@@ -0,0 +1,9 @@
+include ../tools.mk
+
+# Check that symbol names for methods include type names, instead of <impl>.
+
+OUT=$(TMPDIR)/lib.s
+
+all:
+ $(RUSTC) --crate-type staticlib --emit asm lib.rs
+ $(CGREP) Def < $(OUT)