summaryrefslogtreecommitdiffstats
path: root/tests/run-make/symlinked-extern/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/symlinked-extern/Makefile')
-rw-r--r--tests/run-make/symlinked-extern/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/symlinked-extern/Makefile b/tests/run-make/symlinked-extern/Makefile
new file mode 100644
index 000000000..28c764b84
--- /dev/null
+++ b/tests/run-make/symlinked-extern/Makefile
@@ -0,0 +1,12 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# ignore-windows
+# `ln` is actually `cp` on msys.
+
+all:
+ $(RUSTC) foo.rs
+ mkdir -p $(TMPDIR)/other
+ ln -nsf $(TMPDIR)/libfoo.rlib $(TMPDIR)/other
+ $(RUSTC) bar.rs -L $(TMPDIR)
+ $(RUSTC) baz.rs --extern foo=$(TMPDIR)/other/libfoo.rlib -L $(TMPDIR)