summaryrefslogtreecommitdiffstats
path: root/tests/run-make/symlinked-libraries/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/symlinked-libraries/Makefile')
-rw-r--r--tests/run-make/symlinked-libraries/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/run-make/symlinked-libraries/Makefile b/tests/run-make/symlinked-libraries/Makefile
new file mode 100644
index 000000000..fb0b6127e
--- /dev/null
+++ b/tests/run-make/symlinked-libraries/Makefile
@@ -0,0 +1,11 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# ignore-windows
+# `ln` is actually `cp` on msys.
+
+all:
+ $(RUSTC) foo.rs -C prefer-dynamic
+ mkdir -p $(TMPDIR)/other
+ ln -nsf $(TMPDIR)/$(call DYLIB_GLOB,foo) $(TMPDIR)/other
+ $(RUSTC) bar.rs -L $(TMPDIR)/other