summaryrefslogtreecommitdiffstats
path: root/tests/run-make/symlinked-rlib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/symlinked-rlib/Makefile')
-rw-r--r--tests/run-make/symlinked-rlib/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/run-make/symlinked-rlib/Makefile b/tests/run-make/symlinked-rlib/Makefile
new file mode 100644
index 000000000..a8565f683
--- /dev/null
+++ b/tests/run-make/symlinked-rlib/Makefile
@@ -0,0 +1,10 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# ignore-windows
+# `ln` is actually `cp` on msys.
+
+all:
+ $(RUSTC) foo.rs --crate-type=rlib -o $(TMPDIR)/foo.xxx
+ ln -nsf $(TMPDIR)/foo.xxx $(TMPDIR)/libfoo.rlib
+ $(RUSTC) bar.rs -L $(TMPDIR)