summaryrefslogtreecommitdiffstats
path: root/tests/run-make/target-cpu-native/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/target-cpu-native/Makefile')
-rw-r--r--tests/run-make/target-cpu-native/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/run-make/target-cpu-native/Makefile b/tests/run-make/target-cpu-native/Makefile
new file mode 100644
index 000000000..eb3ca1e13
--- /dev/null
+++ b/tests/run-make/target-cpu-native/Makefile
@@ -0,0 +1,20 @@
+include ../tools.mk
+
+# only-linux
+# only-x86_64
+#
+# I *really* don't want to deal with a cross-platform way to compare file sizes,
+# tests in `make` sort of are awful
+
+all: $(TMPDIR)/out.log
+ # Make sure no warnings about "unknown CPU `native`" were emitted
+ if [ "$$(wc -c $(TMPDIR)/out.log | cut -d' ' -f 1)" = "0" ]; then \
+ echo no warnings generated; \
+ else \
+ exit 1; \
+ fi
+
+
+$(TMPDIR)/out.log:
+ $(RUSTC) foo.rs -C target-cpu=native 2>&1 | tee $(TMPDIR)/out.log
+ $(call RUN,foo)