summaryrefslogtreecommitdiffstats
path: root/tests/run-make/target-without-atomic-cas/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/target-without-atomic-cas/Makefile')
-rw-r--r--tests/run-make/target-without-atomic-cas/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/run-make/target-without-atomic-cas/Makefile b/tests/run-make/target-without-atomic-cas/Makefile
new file mode 100644
index 000000000..451f03d66
--- /dev/null
+++ b/tests/run-make/target-without-atomic-cas/Makefile
@@ -0,0 +1,5 @@
+include ../tools.mk
+
+# The target used below doesn't support atomic CAS operations. Verify that's the case
+all:
+ $(RUSTC) --print cfg --target thumbv6m-none-eabi | $(CGREP) -v 'target_has_atomic="ptr"'